Thread is down due to ongoing outage with Cloudflare

Incident Report for Thread

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 18:40 UTC

Update

We are functioning again. As part of this process we are resyncing all tickets to ensure nothing was lost. During the next two to three hours Sync jobs from the admin panel will be delayed until this process is complete. This will also cause a 2 or 3 hour delay on pressing the resync button in inbox.
Posted Nov 18, 2025 - 15:39 UTC

Update

Due to a large scale outage of Cloudflare, the largest CDN and WAF provider on the internet, Thread has had issues over the last 3 hours.

We are migrating our DNS from Cloudflare to Amazon Route53. We have completed the migration of getthread.com, and are migrating remaining domain names. Inbox, Admin, Messenger are back up and running. Teams and Slack are still down.

Thread and PSA may not be in sync over the last 3 hours.
Posted Nov 18, 2025 - 13:53 UTC

Monitoring

We are seeing improvements and currently working to re-enabled webhooks for PSA integrations as they could automatically disable them when services were unavailable.
Posted Nov 18, 2025 - 11:58 UTC

Identified

CloudFlare confirmed an outage: https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 11:49 UTC

Investigating

We are working to better understand the reason for the issue and possible workarounds to restore services, we will follow with an update in 30 mins.
Posted Nov 18, 2025 - 11:45 UTC
This incident affected: Thread RT API, Thread Inbox, Messenger, & Admin, and Thread Message Processing.