HaloPSA webhooks not being processed

Incident Report for Thread

Resolved

This incident has been resolved.
Posted May 22, 2026 - 22:19 UTC

Update

We are continuing to investigate this issue.
Posted May 22, 2026 - 20:55 UTC

Update

We are continuing to investigate this issue.
Posted May 22, 2026 - 20:28 UTC

Update

We are continuing to investigate this issue.
Posted May 22, 2026 - 20:28 UTC

Investigating

We identified an issue that is causing the HaloPSA webhooks to not be processed. We're investigating the issue at the moment and will provide an update as soon as possible.
Posted May 22, 2026 - 20:27 UTC
This incident affected: Thread Inbox, Messenger, & Admin and Thread PSA Pods (HaloPSA Pods).