Teams Service App Creation Issues

Incident Report for Thread

Resolved

We’ve shipped fixes and reliability improvements to the Teams Service app creation and install flow. New app creation should complete normally again. Existing Teams apps were never affected. Thanks for your patience while we investigated.
Posted Apr 22, 2026 - 12:34 UTC

Investigating

We are currently investigating an issue where creating new Teams Service apps is failing or not completing successfully.

Users attempting to create or install a Teams app may encounter errors, timeouts, or see the process fail without completing. Existing Teams apps are not impacted at this time.

Our team is actively investigating the cause and working toward a resolution. We will provide updates as more information becomes available.
Posted Apr 21, 2026 - 20:12 UTC