Teams Custom App Errors On New App Creation

Incident Report for Thread

Resolved

This incident has been resolved.
Posted Aug 12, 2025 - 13:38 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 05, 2025 - 12:13 UTC

Update

We are currently investigating an issue affecting new deployments of Microsoft Teams customer applications and bots. This is due to Microsoft’s recent enforcement of a deprecation related to multi-tenant app and bot support.

Importantly, existing deployments remain fully functional and are not impacted by this change. The issue is limited to attempts to deploy or register new customer-facing Teams apps that rely on multi-tenant configuration.

Our team is working toward a resolution and actively engaging with Microsoft support to clarify deprecation timelines and potential mitigation paths.

We will continue to provide updates as we make progress. Please reach out to help@getthread.com or help.getthread.com if you have any questions or would like a thread to be made to track this and report back directly when resoled.
Posted Aug 04, 2025 - 20:56 UTC

Investigating

This only affects new custom apps and does not affect any existing apps.
Posted Aug 04, 2025 - 14:58 UTC
This incident affected: Microsoft Teams Service and Third Party (Microsoft Teams Integration).