Slack And Teams Messages not arriving to Thread

Incident Report for Thread

Resolved

This incident has been resolved.
Posted Apr 27, 2026 - 18:11 UTC

Update

Our engineering team is still actively investigating the issue with end user messages not syncing to the PSA. We appreciate your patience and will continue to provide updates as we make progress. A further update will be shared shortly.
Posted Apr 27, 2026 - 17:31 UTC

Update

We are currently investigating an issue where messages from Slack or Teams apps are not being synced to the Thread/PSA. Our engineering team is actively looking into the root cause. An update will be provided in approximately 15 minutes.
Posted Apr 27, 2026 - 17:11 UTC

Investigating

We are currently investigating this issue.
Posted Apr 27, 2026 - 13:04 UTC
This incident affected: Microsoft Teams Service.