PSA Webhook delays

Incident Report for Thread

Resolved

This incident has been resolved.
Posted Jul 06, 2026 - 14:45 UTC

Investigating

We are currently experiencing delays in processing a subset of platform events. As a result, some updates may take longer than expected to be reflected in the system.

Our team has identified the issue and has implemented mitigation measures to reduce the backlog and restore normal processing. We are continuing to monitor progress closely.

We will provide another update as more information becomes available.
Posted Jul 06, 2026 - 13:39 UTC
This incident affected: Thread Message Processing.