ITGlue Document Sync failing

Incident Report for Thread

Resolved

This incident has been resolved.
Posted Aug 28, 2026 - 22:38 UTC

Investigating

We're investigating reports of errors and delays affecting IT Glue integrations. A support ticket has been opened with IT Glue and we're working to confirm scope and impact.
Posted Aug 28, 2026 - 21:41 UTC
This incident affected: Third Party (ITGlue).