SSO Login failure

Incident Report for Thread

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 01:37 UTC

Update

We are continuing to investigate this issue.
Posted Mar 10, 2026 - 01:13 UTC

Investigating

We're aware of an issue affecting SSO authentication when logging into Inbox.
As a temporary workaround, please disable SSO and use the One-Time Password (OTP) option to log in. We'll share an update as soon as we have more information.
Posted Mar 10, 2026 - 01:12 UTC