Teams Service App Message delivery issues

Incident Report for Thread

Resolved

This incident has been resolved.
Posted Aug 19, 2025 - 15:50 UTC

Monitoring

A Fix have been implemented and we are monitoring.
Posted Aug 19, 2025 - 14:44 UTC

Investigating

We are aware of a recent spike in failure messages coming from Microsoft Teams.
Posted Aug 19, 2025 - 14:41 UTC
This incident affected: Thread Message Processing.