Flow processing is delayed
Incident Report for Thread
Resolved
This incident has been resolved.
Posted Jan 22, 2025 - 17:52 UTC
Investigating
We are currently investigating this issue.
Posted Jan 22, 2025 - 17:45 UTC
This incident affected: Thread Inbox, Messenger, & Admin.