Inbox slowness due to upstream issues

Incident Report for Thread

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 18:19 UTC

Identified

We are currently experiencing issues with our Inbox platform due to upstream connectivity problems related to Cloudflare, which is impacting dependent services.

As a result, some users may encounter delayed message delivery, intermittent loading issues, or errors when accessing the Inbox. Our core systems remain operational, but performance and availability may be reduced while this upstream issue persists.

We are actively monitoring the situation and coordinating with Cloudflare as they work toward resolution. Updates will be provided as more information becomes available.
Posted Apr 14, 2026 - 12:41 UTC
This incident affected: Thread Inbox, Messenger, & Admin and Thread Message Processing.