Web and Teams Messenger refreshing after login

Incident Report for Thread

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 19:00 UTC

Investigating

We are aware of an issue where some users experience a blinking or flickering screen immediately after signing in to the Messenger web app. Our engineering team is actively investigating the root cause. No user data has been affected.
Posted Apr 24, 2026 - 16:54 UTC
This incident affected: Thread Inbox, Messenger, & Admin.