Delay in real time events from Connectwise

Incident Report for Thread

Resolved

This incident has been resolved.
Posted Feb 09, 2026 - 18:16 UTC

Identified

Identified Issue: ConnectWise is currently experiencing delays in sending webhooks. Delivery may be delayed by up to 30 minutes. We are monitoring the situation and will provide updates as more information becomes available.
Posted Feb 09, 2026 - 16:23 UTC
This incident affected: Thread RT API, Thread Inbox, Messenger, & Admin and Thread PSA Pods (ConnectWise Pods).