ConnectWise NA API degraded performance
Incident Report for Thread
Resolved
Connectwise API hosted in Europe and North America are now fully operational
Posted May 20, 2024 - 10:11 UTC
Update
We have also identified a degraded performance affecting the ConnectWise API's European instance. We are in contact with ConnectWise support to gather more information and will provide updates as soon as they are available.

Thank you for your patience and understanding as we work through this issue.
Posted May 20, 2024 - 08:26 UTC
Identified
ConnectWise API hosted in North America is experiencing degraded performance. This can affect your experience using Thread. We are monitoring and evaluating options to ensure our applications are working properly.
Posted May 20, 2024 - 08:11 UTC
This incident affected: Third Party (ConnectWise API).